Details for testcase: RaspberryPi 2 Post-install



BugReport a bug against the content of this testcase
ID1724
TitleRaspberryPi 2 Post-install
LinkNo link provided
Part of testsuitesARM Server

RevisionWritten on the 2020-06-22 16:29 by brian-murray
Text

This test case is to be carried out on a Raspberry Pi 2.
Follow the installation steps at IoT installation media

During boot, verify that:
You see u-boot output during boot
You see something on the connnected monitor after boot

Once logged in, verify that:

A connected USB keyboard works:
  • when connected to a USB2 (black) port
  • when connected to a USB3 (blue) port
free reports RAM consistent with the specifc device.
The ethernet adapter received an IP address.
  • The device responds to a ping request.
  • It is possible to ssh to the device.
Configure wifi via netplan by creating an /etc/netplan/config.yaml file (example contents below) and running 'sudo netplan apply'. Preferably, wifi will be on a different subnet than ethernet. If that isn't possible disconnect ethernet.
  • network:
  •   version: 2
  •   wifis:
  •     wlan0:
  •       access-points:
  •         "wap_ssid_here":
  •           password: "wap_password_here"
  •       dhcp4: yes
You hear audio output from:
  • the 3.5mm jack
  • HDMI 0
  • HDMI 1
sudo flash-kernel produces no error messages
sudo reboot reboots the device
sudo shutdown -h now powers off the device
Performing a large (300-600mb) file copy to USB storage works
  • Copy the large file to USB storage
  • sync
  • Check dmesg for errors
  • Unmount and remount the USB storage
  • Verify the md5sum of the file

Boot with the 2nd HDMI port connected. Verify that you see output on the 2nd monitor instead of the 1st.

If all actions produce the expected results listed, please submit a 'passed' result.
If an action fails, or produces an unexpected result, please submit a 'failed' result and file a bug. Please be sure to include the bug number when you submit your result
.

RevisionWritten on the 2020-06-22 16:26 by brian-murray